Составьте программу ** языке Паскаль: Поменять местами первую и последнюю цифры...

0 голосов
202 просмотров

Составьте программу на языке Паскаль: Поменять местами первую и последнюю цифры четырёхзначного числа. Очень срочно помогите пожалуйста!


Информатика (134 баллов) | 202 просмотров
0

10 минут

Дано ответов: 2
0 голосов
Правильный ответ

Var a,a1,a2,a3,a4;
begin
read (a);
a1:=a div 1000;
a2:=a div 100 mod 10;
a3:=a div 10 mod 10;
a4:=a mod 10;
a:=a4*1000+a2*100+a3*10+a1;
write (a);
end.

(674 баллов)
0 голосов

Uses Crt;
var   x : Integer; 
Zn:Char; 
strNum:string;  
begin  
ClrScr; 
Write('Введите четырех значное число: '); 
ReadLn(x);   
Str(X,strNum); 
Zn:=strNum[1]; 
strNum[1]:=strNum[Length(strNum)]; 
strNum[Length(strNum)]:=Zn; 
x:=StrToInt(StrNum); 
writeln(strNum);
end.

(160 баллов)