1. Напишите программу, которая вводит трехзначное число и разбивает его ** цифры....

0 голосов
453 просмотров

1. Напишите программу, которая вводит трехзначное число и разбивает
его на цифры. Например, при вводе числа 123 программа должна
вывести 1, 2, 3.
2. Напишите программу, которая вводит возраст человека (число, не
превосходящее 120) и выводит на экран этот возраст со словом «»год,
«года» , «лет» . например «21 год», «22 года», «15 лет»

Помогите пожалуйста !!!!


Информатика (30 баллов) | 453 просмотров
Дан 1 ответ
0 голосов

1 задача
program proga;
var st,st2:string;
i:Integer;
begin
writeln('Введите число');
readln(st);
for i:=1 to length(st) do begin
st2:=st[i];
write(st2,' ');
end;
end.
2 задача
program proga2;
var st,st2:string;
i,a:Integer;
begin
writeln('Введите возраст');
readln(a);
if a>120 then
writeln('Неверные данные');
if a=1 then
writeln(a,' год');
if (a>1) and (a<5) then<br>writeln(a,' года');
if((a mod 10 = 1) and (a div 10 <> 0 or 11 )) then writeln(a,' год');
if (a>=5) and (a mod 10 <> 2 or 3 or 4)and (a div 10 <> 10) then
writeln(a,' лет');
if (a<=5) and (a mod 10 = 2 or 3 or 4)and (a div 10 = 10) then writeln(a,' года ');<br>if(a>104) and (a<110)then writeln(a,' лет'); <br>end.



(237 баллов)
0

2 задача

0

может 2 можно подругому запилить но думать мне особо не хотелось сделал как сделал

0

спасибо огроное