Написать программу которая выводит ** экран значений функции у=|х|. диапазон изменения...

0 голосов
48 просмотров

Написать программу которая выводит на экран значений функции у=|х|. диапазон изменения аргумента-от4 до -4, шаг приращения -(-0.5)


Информатика (237 баллов) | 48 просмотров
Дано ответов: 2
0 голосов

Если я правильно понял,то так
uses crt;
varx,y:real;
beginx:=4;
while x>(-4.5) do begin
y:=abs(x);
x:=x+(-0.5);
write(y,' ');
end;
end.

(332 баллов)
0 голосов

Вот так:
const
  LB=-4;
  HB=4;
  DX=0.5;
var
  x,y : real;
  n,i :integer;
begin
   writeln('значения');
   n:=round((HB-LB)/DX)+1;
   x:=LB;
  for i:= 1 to n do
     begin
        y:=abs(x);
        writeln(x:6:2,y:6:2);
        x:=x+DX;
     end;
end.

(202 баллов)