Составить программу ,находящую кол-во и сумму цифр пяти данных целых чисел ,используя...

0 голосов
32 просмотров

Составить программу ,находящую кол-во и сумму цифр пяти данных целых чисел ,используя процедуру


Информатика (66 баллов) | 32 просмотров
Дан 1 ответ
0 голосов
Правильный ответ

Var i,x,k,s:integer;

function Sum(x:integer):integer;
var
   t:string;
   i:integer;
begin
s:=0;
t:=IntToStr(x);
for i:=1 to length(t) do s:=s+StrToInt(t[i]);
result:=s
end;

function Kol(x:integer):integer;
var t:string;
begin
t:=IntToStr(x);
result:=length(t)
end;

begin
for i:=1 to 5 do
  begin
  write('Введите число ',i,': '); 
  readln(x); 
  k:=Kol(x); 
  s:=Sum(x); 
  writeln('Количество цифр ',k,'; сумма цифр ',s)
  end
end.

0

Программа находит для каждого из 5 чисел. Хотя условие можно понять и так: для всех 5 чисел. Тогда другая программа нужна.