Составить программу проверки есть ли в тексте буква "s".Напишите ** C++

0 голосов
82 просмотров
Составить программу проверки есть ли в тексте буква "s".
Напишите на C++

Информатика (138 баллов) | 82 просмотров
Дан 1 ответ
0 голосов
#include "stdafx.h"
#include
#include

using namespace std;

int _tmain(int argc, _TCHAR* argv[])
{
    bool s = false;
    char fn[255];
    cout << <em>"Filename: " << endl;<br>
    cin >> fn;
    ifstream fin(fn);
    while(!fin.eof())
       if (fin.get() == 's')
       {
          s = true;
break;
       }
    fin.close();
    cout << <em>"There " << (s ? <em>"is" : "isn't") << endl;<br>    system("pause");
    return 0;
}
(16.9k баллов)