Помогите с паскалем! Написать программу. Составить блок схему.Вставить заданное число в...

0 голосов
23 просмотров

Помогите с паскалем! Написать программу. Составить блок схему.
Вставить заданное число в массив целых чисел перед последним четным элементом.


Информатика (19 баллов) | 23 просмотров
Дан 1 ответ
0 голосов
Правильный ответ

Const
    m = 10; 
var
    a: array[1..m+1] of integer;
    i, k: integer;
begin     
write ('Исходный массив: ');   
for i := 1 to m do
  begin
  a[i] := random(100);
  write (a[i],'; ');
  end;   
writeln; 
write('Введите число: ');
readln(k);
for i:=m+1 downto 1 do
  begin
  a[i]:=a[i-1];
  if a[i] mod 2=0 then
    begin
    a[i-1]:=k;
    break;
    end;
  end;
write('Измененный массив: ');  
for i := 1 to m+1 do
         write (a[i],'; ');  
end.


image
image
0

Спасибо!