Написать программу вывода ** экран всех простых чисел до 200

0 голосов
61 просмотров

Написать программу вывода на экран всех простых чисел до 200


Информатика (201 баллов) | 61 просмотров
0

с++ пойдет?

0

на паскале можно

0

вывод все простые числа до заданого значения

0

выводит

Дан 1 ответ
0 голосов
program PrimesToN;
var i, k, n, count: word;
begin readln(n); for k := 1 to n do begin count := 0; for i := 1 to k do begin if k mod i = 0 then inc(count) end; if count = 2 then write(k, ' ') end end.

(40 баллов)
0

спс