Написать программу, которая проверяет – образуют ли элементы заданного массива...

0 голосов
76 просмотров

Написать программу, которая проверяет – образуют ли элементы заданного массива возрастающую последовательность.


Информатика (18 баллов) | 76 просмотров
Дан 1 ответ
0 голосов

Var arr : array of integer; len, i : integer; begin write('Введите размер массива: '); readln(len); SetLength(arr, len); for i := 0 to len -1 do begin write('arr[', i, '] = '); readln(arr[i]); end; for i := 1 to len - 1 do if arr[i] <= arr[i - 1] then begin writeln('Последовательность не возрастающая'); Exit; end; writeln('Последовательность возрастающая'); end.

(918 баллов)
0

Извиняюсь, что без переходов, мобильная версия не хочет их вставлять

0

надо на паскаль

0

надо конкретнее. Это Pascal ABC.NET. Есть ещё ABC, турбо паскаль, free Pascal, на каком именно нужно?

0

ABC

0

const
len = 3;
var
arr : array [1..len] of integer;
i : integer;
begin
writeln('Äëèíà ìàññèâà: ', len);
for i := 1 to len do
begin
write('arr[', i, '] = ');
readln(arr[i]);
end;
for i := 2 to len do
if arr[i] <= arr[i - 1] then<br> begin
writeln('Ïîñëåäîâàòåëüíîñòü íå âîçðàñòàþùàÿ');
Exit;
end;
writeln('Ïîñëåäîâàòåëüíîñòü âîçðàñòàþùàÿ');
end.

0

const
len = 3;
var
arr : array [1..len] of integer;
i : integer;
begin
writeln('Длина массива: ', len);
for i := 1 to len do
begin
write('arr[', i, '] = ');
readln(arr[i]);
end;
for i := 2 to len do
if arr[i] <= arr[i - 1] then<br> begin
writeln('Последовательность не возрастающая');
Exit;
end;
writeln('Последовательность возрастающая');
end.