Нужно сделать в Паскале:Составьте программу, составьте программу, которая вычисляет...

0 голосов
45 просмотров

Нужно сделать в Паскале:

Составьте программу, составьте программу, которая вычисляет произведение чисел от 1 до n. Где n вводится с клавиатуры.


Информатика | 45 просмотров
Дан 1 ответ
0 голосов
Правильный ответ

Var p,i, n:integer;

begin
   p:=1;
   writeln('Введи n');
   readln(n);
   if n>=1 then
    begin
    for i:=1 to n do
    p:=p*i;
    writeln(p);
    end else writeln('n>=1');
end.

(1.3k баллов)