ОЧЕНЬ НУЖНА ПОМОЩЬ ДО ЗАВТРА!!1 ПОМОГИТЕ!!Напишите эффективную программу, которая по двум...

0 голосов
99 просмотров

ОЧЕНЬ НУЖНА ПОМОЩЬ ДО ЗАВТРА!!1 ПОМОГИТЕ!!
Напишите эффективную программу, которая по двум данным натуральным числам p и q не превосходящим 30 000, подсчитывает кол-во натуральных чисел с последней цифрой 0 на интервале (p,q) (не включая концы интервала)
Программа получает на вход 2 натуральных числа p и q, при этом гарантируется, что 1≤pПроверять входные данные на корректность не нужно.
Программа должна вывести одно число: кол-во натуральных чисел с последней цифрой 0 на отрезке (p,q)


Информатика (25 баллов) | 99 просмотров
Дан 1 ответ
0 голосов

Код программы для С#. Думаю при желании можно запросто переписать на любой другой язык программирования.

Console.WriteLine("Введите p");

 double p = Convert.ToInt16(Console.ReadLine());


Console.WriteLine("Введите q");


double q = Convert.ToInt16(Console.ReadLine());


int c = 0;   


double x = 0; 


 for (double i = p + 1; i < q - 1; i++) { x = i % 10; if (x == 0) c++; }           

Console.WriteLine("----------------");   


Console.WriteLine("Количество натуральных чисел с последней цифрой 0 на отрезке (p,q) = "+ c);         
     


 Console.ReadLine();

При желании могу скинуть уже готовую программу.

(1.1k баллов)