Помогите пожалуйста! Срочно надо написать программу в паскале. Задание: Введите три...

0 голосов
37 просмотров

Помогите пожалуйста! Срочно надо написать программу в паскале. Задание: Введите три трёхзначных числа. Найти разность между наибольшим м наименьшим. Заранее спасибо!


Информатика (59 баллов) | 37 просмотров
Дан 1 ответ
0 голосов

Begin
  var a, b, c: single;
  readln(a, b, c);
  writeln(max(a, max(b, c)) - min(a, min(b, c)));
end.

Позязя, расширеннее...
begin
  var a, b, c, d, e: single;
  readln(a, b, c);
  if (a < b) then
    d := a
  else
    d := b;
  if (c < d) then
    d := c;
  if (a > b) then
    e := a
  else
    e := b;
  if (c > e) then
    e := c;
    writeln(e - d);
end.

(16.9k баллов)
0

а можно более пазвёрнуто

0

развёрнуто

0

Спасибо огромное!!!!!!!!!