Написать программу в Pascal ABC чтобы полностью работала, которая ввод данных в...

0 голосов
38 просмотров
Написать программу в Pascal ABC чтобы полностью работала, которая ввод данных
в одномерный целочисленный массив осуществляет посредством цикла WHILE…DO, а вывод - REPEAT…UNTIL (в скобках указана размерность
массива).




Заменить последний элемент массива
минимальным (10)

Информатика (1.0k баллов) | 38 просмотров
0

Элементы с клавиатуры вводить или автоматически заполнить?

0

Последний эл-т просто заменить на минимальный, или поменять с ним местами?

0

с клавиатуры писать любые числа

0

просто заменить

Дан 1 ответ
0 голосов
Правильный ответ

Var
  i,min:integer;
  a:array[1..10]of integer;
begin
i:=1;
while i<11 do<br>  begin
  readln(a[i]);
  if i=1 then min:=a[1];
  if a[i]  i:=i+1;
  end;
writeln('Исходный массив:');
i:=1;
repeat
  write(a[i],' ');
  i:=i+1;
  until i>10;
a[10]:=min;
writeln;
writeln('Измененный массив:');
i:=1;
repeat
  write(a[i],' ');
  i:=i+1;
  until i>10;
end.

0

большое спасибо