Два игрока А и В бросают кубик N раз, суммируя результаты бросков. Напишите программу...

0 голосов
98 просмотров

Два игрока А и В бросают кубик N раз, суммируя результаты бросков. Напишите программу определяющую победителя после N бросков.


Информатика (26 баллов) | 98 просмотров
0

они суммируют каждый для себя, те две суммы получается?

0

Получается, что, так.

Дан 1 ответ
0 голосов

Var  n, i, sum1, sum2, buf: integer;
begin 
writeln('Введите количество бросков'); 
readln(n); 
sum1 := 0; 
sum2 := 0; 
 i := 0;   
 for i := 1 to n do 
begin   
writeln('Введите значения на кубиках после броска № - ', i, ' на кубике человека по имени А ');   
readln(buf);   
 sum1 := sum1 + buf; 
end;   
 
for i := 1 to n do 
 begin   
writeln('Введите значения на кубиках после броска № - ', i, ' на кубике человека по имени B');   
readln(buf);   
sum2 := sum2 + buf; 
end;   
 if sum1 = sum2 then writeln('Ничья') else  
 if sum1 > sum2 then writeln('Победил человек по имени А')
else     writeln('Победил человек по имени B');  
end. 
Как то так ... 

(380 баллов)
0

мне кажется она не совсем то имела ввиду)

0

Господи, большое вам спасибо.

0

а, нет, то)

0

Все то, что надо :-)