1). Дан миссив из n целых чисел. Напишите программу определяющую сколько в массиве четных...

0 голосов
48 просмотров

1). Дан миссив из n целых чисел. Напишите программу определяющую сколько в массиве четных чисел,

2). Дан массив из n целых чисел. Напишите программу определяющую каких элементов в точке больше положительных или отрицательных


Информатика (12 баллов) | 48 просмотров
Дан 1 ответ
0 голосов

Program BiFi;
Const n=50;
Var A:array[1..n] of integer;
i,c,l:integer;
Begin
for i:=1 to n do readln(A[i]);
c:=0;
for i:=1 to n do if A[i] mod 2 = 0 then c:=c+1;
writeln(c);
readln;
end.


Program BiFi;
Const n=50;
Var A:array[1..n] of integer;
i,k,l:integer;
Begin
k:=0;
l:=0;
for i:=1 to n do begin readln(a[i]);
                      if A[i]<0 then k:=k+1 <br>                                  else if A[i]>0 then l:=l+1;
                      end;
if k>l then writeln('больше положительных')
        else if l>k then writeln('больше отрицательных')
                       else writeln('одинаково');
readln;
end.

(1.0k баллов)