Написать программу в PascalABC.NET задание:с клавиатуры вводятся 3 числа.найти среднее...

0 голосов
70 просмотров

Написать программу в PascalABC.NET

задание:с клавиатуры вводятся 3 числа.найти среднее арифметическое двух больших и двух меньших.


Информатика (68 баллов) | 70 просмотров
Дан 1 ответ
0 голосов

по нубски правдо очень проверить не забудь)

var
a,n,c:integer;
x,y:real;
begin
readln(a);
readln(n);
readln(c);
if ((a > n) and (n > c)) then begin
x:=(a+n)/2;
y:=(n+c)/2;
end else if((n > a) and (a > c)) then begin
x:=(a+n)/2;
y:=(a+c)/2;
end else if((c > a) and (a > n)) then begin
x:=(a+c)/2;
y:=(a+n)/2;
end else if((c > n) and (n > c)) then begin
x:=(c+n)/2;
y:=(n+c)/2;
end else if((n > c) and (c > a)) then begin
x:=(c+n)/2;
y:=(a+c)/2;
end else if((a > c) and (c > n)) then begin
x:=(c+a)/2;
y:=(n+c)/2;
end else if((c > n) and (n > a)) then begin
x:=(c+n)/2;
y:=(n+a)/2;
end;
write('наибольшее: ',x,' наименьшее: ',y);
end.

(22 баллов)