ПОМОГИТЕ С ПРОГРАММОЙ, ПОЖАЛУЙСТА!нужно написать программу, которая по вводу с клавиатуры...

0 голосов
24 просмотров

ПОМОГИТЕ С ПРОГРАММОЙ, ПОЖАЛУЙСТА!
нужно написать программу, которая по вводу с клавиатуры последовательности целых чисел (признак окончания ввода- ввод числа 0) подсчитывает среднее арифметическое НЕЧЕТНЫХ чисел и чисел, КРАТНЫХ 5.


Информатика (37 баллов) | 24 просмотров
0

аа мне тоже нужна эта задача

Дано ответов: 2
0 голосов

Var
   A,i:integer;
   B:real;
Begin
repeat
Writeln('Введи число.');
ReadLn(A);
if (A mod 10 =0) then
 Begin
  i:=i+1;
  B:=A+B;
 End;
until (A=0);
WriteLn('Среднее арифметическое нечетных чисел кратных 5 равно: ',B/(i-1));
ReadLn
End.

(84 баллов)
0 голосов

Var x,i:integer;
   y:real;
Begin
writeln('Признак окончания ввода - ввод числа 0');
repeat
Writeln('Введите число');
ReadLn(x);
if (x mod 2 >0) and (x mod 5 = 0) then 
Begin  i:=i+1; 
 y:=x+y; 
End;
until (x=0);
WriteLn('Среднее арифметическое нечетных чисел кратных 5 = ',y/i);
End.

(1.1k баллов)