Программирование циклов. Составьте программу.C клавиатуры вводят 6 целых чисел....

0 голосов
62 просмотров

Программирование циклов. Составьте программу.
C клавиатуры вводят 6 целых чисел. Определите количество четных чисел в этом наборе.


Информатика (41 баллов) | 62 просмотров
Дан 1 ответ
0 голосов

Program ten;
const n=2;
Var a,b,c,d,e,f,p:integer;
Begin 
Write ('Введите число a '); Read(a);
Write ('Введите число b '); Read(b);
Write ('Введите число c '); Read(c);
Write ('Введите число d'); Read(d);
Write ('Введите число e '); Read(e);
Write ('Введите число f '); Read(f);
p:=0;
If a mod n = 0 Then P:=p+1;
If b mod n = 0 Then P:=p+1;
If c mod n = 0 Then P:=p+1;
If d mod n = 0 Then P:=p+1;
If e mod n = 0 Then P:=p+1;
If f mod n = 0 Then P:=p+1;
Write ('количество четных чисел = ',p);
end.
 Вот так, программа работает.

(378 баллов)