Написать программу, которая определяет, делителем каких чисел (среди трех введенных)...

0 голосов
44 просмотров
Написать программу, которая определяет, делителем каких чисел (среди трех введенных) является число Z. (Язык программирования - Паскаль)

Информатика (91 баллов) | 44 просмотров
Дан 1 ответ
0 голосов
Правильный ответ

Var
  A, B, C, Del : integer;
begin
  write('Введите число A: ');
  readln(A);
  write('Введите число B: ');
  readln(B);
  write('Введите число C: ');
  readln(C);
  write('Введите делитель: ');
  readln(Del);
  write('Число ', Del, ' является делителем таких чисел: ');
  if A mod Del = 0 then write(A, ' ');
  if B mod Del = 0 then write(B, ' ');
  if C mod Del = 0 then write(C, ' ');
end.

(918 баллов)