5. Точка А задана координатами X,Y. Написать программу, которая выводит...

0 голосов
230 просмотров

5. Точка А задана координатами X,Y. Написать программу, которая выводит слово«Принадлежит», если точка принадлежит заштрихованной области (см. рисунок 5) и «Не принадлежит» в противном случае. Программа должна иметь дружественный интерфейс. Протестировать программу для точек (0,0), (1.5,1), (2,1), (1,-1), (-0.5,-0.2), (-2,-1), (-1,-2), (-1,1), (-3, 1).


image

Информатика (35 баллов) | 230 просмотров
Дан 1 ответ
0 голосов
Правильный ответ

Program chik;
var x,y:real;
begin
readln(x,y);
if((y<=2)and(x>=-3)and(x<=2)and(y>=0))or
((y<=0)and(x>=-1)and(x<=1)and(y>=-1)and(x*x+y*y<=1))then <br>writeln('ПРИНАДЛЕЖИТ')else writeln('Не принадлежит');
end.

(6.6k баллов)