Нужно подробное написание программы в pascalABC1) С клавиатуры вводится число в интервале...

0 голосов
42 просмотров

Нужно подробное написание программы в pascalABC
1) С клавиатуры вводится число в интервале от 1 до 999. Написать программу, которая определяет количество цифр во введенном числе.
2) Написать программу, которая определяет, какая из двух точек расположена ближе к началу координат. Координаты вводятся с экрана.


Информатика (95 баллов) | 42 просмотров
Дан 1 ответ
0 голосов
program name;
var i,n,x,summa,count:integer;
nechet:boolean;
begin
Writeln('Vvedite n: ');
readln(n);//получаем n
summa:=0;
count:=0;
i:=1;
if(n mod 2 = 1) then nechet := true else nechet := false; //проверяем четное число или нет
while iif(nechet) then//если число нечентное
begin
summa:=summa+i*i*i;//прибавляем к сумме куб этого числа
end
else//если число четное
begin
summa:=summa+i*i;//прибавляем квадрат числа
end;
i:=i+1;//прибавляем число на 1
end;
writeln(' summa: ', summa);//выводим сумму
readln();
end.
(162 баллов)
0

это решение к какой-то другой задаче. при чем здесь четность-нечетность?

0

ок перепутал