Написать программу, которая добавляет пробелы в строку.(То есть: Если в тексте есть знак...

0 голосов
49 просмотров

Написать программу, которая добавляет пробелы в строку.(То есть: Если в тексте есть знак препинания «.», «,», «!» или «?», и после отсутствует пробел)


Информатика (153 баллов) | 49 просмотров
Дан 1 ответ
0 голосов
Правильный ответ

Var
  s1,s2:string;
  i,k:integer;
begin
readln(s1);
k:=length(s1)-1;
s2:='';
for i:=1 to k do
  begin
    s2:=s2+s1[i];
    case s1[i] of
      '.',',','!','?':
        if s1[i+1]<>' ' then s2:=s2+' ';
    end;
  end;
s2:=s2+s1[k+1];
writeln(s2)
end.