напишите программу, которая вычисляет сумму: а) первых n натуральных чисел б) квадраов...

0 голосов
43 просмотров

напишите программу, которая вычисляет сумму:

а) первых n натуральных чисел

б) квадраов первых n натуральных чисел

в) всех четных чисел в диапозоне от 1 до n

г) всех двухзначных чисел


Информатика (23 баллов) | 43 просмотров
0

(паскаль)

0

Паскаль, школьный курс.

0

это в одной программе или в нескольких можно?

0

в нескольких

0

а в одной не устроит?!)))

0

просто уже почти написал, последнее осталось)))

0

хорошо:)

0

так, всех существующих двузначных или двузначных до некоего Н?

0

всех двухзначных... в учебнике так)

0

ок)

Дан 1 ответ
0 голосов
Правильный ответ

Program D1LPxx10;
uses crt;
var
i,n,sum4,sumkv,sum4et,sumdvy:integer;
begin
read(n);
for i:=1 to n do
sum4:=sum4+i;
for i:=1 to n do
sumkv:=sumkv+i*i;
for i:=1 to n do
if i mod 2=0 then
sum4et:=sum4et+i;
for i:=10 to 99 do
sumdvy:=sumdvy+i;
writeln('summa=',sum4,' summa kvadratov=',sumkv,' summa 4etnblx=',sum4et,' summa dvyzna4nblx=',sumdvy);
end.

(510 баллов)