Написать программу расчета функции y=cos(x)*π/x с шагом 0,1 в диапазоне от b до 5, с...

0 голосов
83 просмотров

Написать программу расчета функции y=cos(x)*π/x с шагом 0,1 в диапазоне от b до 5, с проверкой диапазона
на программу паскаль


Информатика (77 баллов) | 83 просмотров
Дан 1 ответ
0 голосов
Правильный ответ

Var x,y,b:real;
begin
b:=6;
while b>=5 do
  begin
  writeln('Введите параметр b (b<5): ');<br>  readln(b);
  end;
x:=b;
writeln('x':2,'y':6);
repeat  y:=cos(x)*Pi/x;
  writeln(x:3:1,' ',y);
  x:=x+0.1;
  until x>5;
end.