Написать программу:"Дано четырехзначное число.Что больше:сумма цифр,стоящих ** четных...

0 голосов
66 просмотров
Написать программу:"Дано четырехзначное число.Что больше:сумма цифр,стоящих на четных местах,или сумма цифр,стоящих на не четных местах?"

Информатика (15 баллов) | 66 просмотров
Дан 1 ответ
0 голосов
Правильный ответ

Var a,s1,s2:integer;
begin
read (a);
if (a>=1000)and (a<=9999)then <br>begin
s1:=(a mod 10) + ((a mod 1000) div 100);
s2:=(a div 1000) + ((a mod 100) div 10);
if (s1>s2)then writeln ('Сумма цифр,стоящих на четных местах больше суммы цифр, стоящих на нечетных местах');
if (s1if (s1=s2)then writeln ('Сумма цифр,стоящих на четных местах равна сумме цифр, стоящих на нечетных местах');
end
else writeln ('Вы ввели не 4-ёхзначное число');
end.