Напишите программу,которая вычисляет сумму:а)первых n натуральных чисел;б)квадратов...

0 голосов
54 просмотров

Напишите программу,которая вычисляет сумму:
а)первых n натуральных чисел;
б)квадратов первых n натуральных чисел


Информатика (12 баллов) | 54 просмотров
Дан 1 ответ
0 голосов

Решение на паскале:
а)
var sum,i,n: int64;
BEGIN
writeln('Введите N');
readln(n);
for i := 1 to n do
sum := sum + i; // можно написать так inc(sum, i);
writeln('Сумма первых ', n, ' натуральных чисел = ', sum);
END.
б)
var sum,i,n: int64;
BEGIN
writeln('Введите N');
readln(n);
for i := 1 to n do
sum := sum + sqr(i); 
writeln('Сумма квадратов первых ', n, ' натуральных чисел = ', sum);
END.

(18 баллов)