Программа выполняется в Паскале! Составьте программу для решения следующей задачи:Дядюшка...

0 голосов
35 просмотров
Программа выполняется в Паскале! Составьте программу для решения следующей задачи:Дядюшка подарил своему племяннику на первый день рождения 1 доллар. В каждый следующий день рождения он удваивал свой подарок и прибавлял к нему столько долларов, сколько лет исполнилось его племяннику. Определите, к какому дню рождения сумма превысит 100 долларов? Помогите плииз.

Информатика (77 баллов) | 35 просмотров
0

если не трудно, то отметь "как лучшее"))

Дан 1 ответ
0 голосов

Var money,n,count:integer;
 begin
money:=1;
n:=0;
while money < 100 do 
begin
money:= money*2+n;
n:=n+1;
count:=count+1;
end;
writeln(count);
end.

(800 баллов)