Нужно написать программу в ПАСКАЛЕОписать функцию Quarter(x, y) целого типа, определяющую...

0 голосов
81 просмотров

Нужно написать программу в ПАСКАЛЕ
Описать функцию Quarter(x, y) целого типа, определяющую номер координатной четверти, в которой находится точка с ненулевыми вещественными координатами (x, y). С помощью этой функции найти номера координатных четвертей для трех точек с данными ненулевыми координатами.


Информатика (16 баллов) | 81 просмотров
Дан 1 ответ
0 голосов

Var
   i: integer;
   x,y:real;

function Quarter(x,y:real):integer;
begin
if (x>0) and (y>0) then result:=1;
if (x<0) and (y>0) then result:=2;
if (x<0) and (y<0) then result:=3;<br>if (x>0) and (y<0) then result:=4;<br>end;

begin
writeln('Введите координаты точки');
readln(x,y);
i:=Quarter(x,y);
writeln('Номер координатной четверти; ',i)
end.