Помогите составить программу по Паскаль АВС для решения уравнения. программа с функциями...

0 голосов
40 просмотров

Помогите составить программу по Паскаль АВС для решения уравнения. программа с функциями что ли
5х^2-4х/х^3, х>0
5х^2-4х/х, х=0
5х^2-4х, х<0<br> это система. заранее благодарна тому, кто сможет мне помочь)счастья тебе


Информатика (70 баллов) | 40 просмотров
0

если помогло, можешь сделать ответ лучшим? ;)

0

Странно система выглядит. Ошибки нет? Вторая строчка, если ее заранее не упростить, вызовет сбой программы - на 0 делить нельзя.

Дан 1 ответ
0 голосов

Var x:integer;y:real;
begin
write('Введите х');
read(x);
if x>0 then y:=5*exp(2*ln(x)) - 4*х/exp(3*ln(x));
if x=0 then y:=5*exp(2*ln(x)) - 4;
if x<0 then y:=5*<span>exp(2*ln(x)) - 4*x;
writeln('f(x)=',y);
end.

(1.2k баллов)
0

только я не могу понять почему в уравнениях вместо деления стоит минус. так и должно быть?

0

Я по твоим уравнениям писала оО Если интересует, то exp(2*ln(x))=x*x, exp(3*ln(x))=x*x*x А в остальном всё так же

0

5х^2-4х/х^3, х>0
5х^2-4х/х, х=0
5х^2-4х, х<0 - вот эта система в твоём вопросе

0

ой! все правильно. я сама перепутала:D спасибо большое)

0

если помогло, можешь сделать ответ лучшим? ;)

0

а как?я не совсем умею(

0

чёрт, я тоже :D мне тут ни разу не ответили