Написать программу, которая вычисляет, сколько купюр и какого достоинства нужно отдать в...

0 голосов
97 просмотров
Написать программу, которая вычисляет, сколько купюр и какого достоинства нужно отдать в кассу, чтобы оплатить покупку в S рублей. Известно, что у покупателя имеются купюры достоинством 500 р., 100р. и 50р., а расплачиваться он начинает с самой крупной.(Язык программирования - Паскаль)

Информатика (91 баллов) | 97 просмотров
Дан 1 ответ
0 голосов
Правильный ответ

....................................


image
(140 баллов)
0

Косячно написана) (Он не считает 500-ых купюрные)
var
a, b, c, s: integer;
begin
write('Введите S = '); readln(s);
while s > 500 do
begin
s := s - 100;
b := b + 1;
end;
while s >= 50 do
begin
s := s - 50;
c := c + 1;
end;
writeln('Нужно ', a, ' 500-ых купюр / ', b, ' 100-ых купюр / ', c, ' 50-ых купюр');
end.