написать программу, которая для трёхзначного числа, если оно четное, то возводит в...

0 голосов
30 просмотров

написать программу, которая для трёхзначного числа, если оно четное, то возводит в квадрат, а если нечётное, то находит сумму цифр.


Информатика (31 баллов) | 30 просмотров
Дан 1 ответ
0 голосов

Var a:integer;
begin
readln(a);
if a mod 2 = 0 then writeln(a*a) else
writeln((a div 100) + (a mod 10) + ((a mod 100) div 10));
end.

(4.7k баллов)