(в паскале помогите написать программу) Оставьте в строке только первые вхождения букв, все повторяющиеся буквы удалите. Например, исходное слово «кроссворд» (или «missisipi»), результат «кросвд» (или «misp»).
Var i,x:integer; s:string; begin readln(s); for i:=length(s) downto 1 do begin x:=pos(s[i],s); if x<>i then delete(s,i,1); end; writeln(s) end.