Даны целые числа x и y. Написать программу определения знака разности x-y. Разность...

0 голосов
75 просмотров

Даны целые числа x и y. Написать программу определения знака разности x-y. Разность вычислять нельзя. Разрешается сравнивать числа x и y с нулем, а между собой можно сравнивать только абсолютные величины чисел x и y.


Информатика | 75 просмотров
Дан 1 ответ
0 голосов

Program raznost_xy;
var x, y:integer;
begin
write ('Введите число х = ');
readln (x);
write ('Введите число у = ');
readln (y);

if (x>0) and (y>0) then
  begin
    if abs(x)>abs(y) then write ('x-y > 0');
    if abs(x)=abs(y) then write ('x-y = 0');
    if abs(x)  end;
      
if (x<0) and (y<0<span>) then
  begin
    if abs(x)>abs(y) then write ('x-y < 0');
    if abs(x)=abs(y) then write ('x-y = 0');
    if abs(x) 0');
  end;

if (x=0) and (y=0) then write ('x-y = 0');
if (x>0) and (y<0) then write ('x-y > 0');
if (x<0) and (y>0) then write ('x-y < 0');
if (x=0) and (y>0) then write ('x-y < 0');
if (x=0) and (y<0) then write ('x-y > 0');
if (x>0) and (y=0) then write ('x-y > 0');
if (x<0) and (y=0) then write ('x-y < 0');<br>end.

(256 баллов)