Составить программу расчета нормы полива в теплице (л/м) по формуле:M=0,1*h*d*(-),гдеh–...

0 голосов
29 просмотров

Составить
программу расчета нормы полива в теплице (л/м) по формуле:M=0,1*h*d*(W_{1}-W_{2}),

где
h

высота слоя грунта, см;
d

объемная масса грунта, г/см3;
W1 – рекомендуемая относительная
влажность грунта, % ППВ; W2
– фактическая относительная влажность грунта, % ППВ.


Фактическая относительная влажность грунта изменяется
в пределах от 50 до 60 % ППВ с шагом 1 %.


Информатика (28 баллов) | 29 просмотров
Дан 1 ответ
0 голосов
//Если я правильно понял, то так...
var

  d, h, w1, w2: integer;

function readvalue(s: string): integer;
var t: integer;
begin
  write(s, ' ');
  readln(t);
  result := t;
end;

begin
  h := readvalue('Высота слоя грунта:');
  d := readvalue('Объём грунта:');
  w1 := readvalue('Рек. влажность грунта:');
  writeln('Вл. грунта | Норма полива');
  for w2 := 50 to 60 do
    writeln(w2:9, '% | ', 0.1*h*d*(w1-w2), ' л/м');
end.
(16.9k баллов)