Построить блок-схему и написать программу 1. Вычислить S=1+2+3+4+…+N 2. Для данного N...

0 голосов
80 просмотров

Построить блок-схему и написать программу
1. Вычислить S=1+2+3+4+…+N
2. Для данного N составить алгоритм вычисления факториала N!=1*2*3*…*N


Информатика (33 баллов) | 80 просмотров
Дан 1 ответ
0 голосов

1.
 program z;
var n,i:integer; s:real;
begin
writeln('Введите число n'); readln(n);
for i:=1 to n do
begin
s:= (n*(n+1))/2; end;
writeln(s); 
end.
2. program z2;
var s,i,n:integer;
begin
writeln('Введите число n '); readln (n);
s:=1;

for i:=1 to n do s:=s*i;

write(s); end.

(310 баллов)
0

спасибо