Написать программу ** С++, которая будет выводить прямоугольный двумерный массив,...

0 голосов
31 просмотров

Написать программу на С++, которая будет выводить прямоугольный двумерный массив, A[N][M], N и M вводятся с клавиатуры, элементы массива генерируются случайным образом
З.Ы. если что среда разработки - Qt


Информатика (23 баллов) | 31 просмотров
Дан 1 ответ
0 голосов

Это невозможно. N и M должны быть константными значениями. То есть в виде переменных их не сделать => ввести с клавиатуры значения для константных значений нельзя. Можно сделать элементы массива рандомными:


#include
int main() {
cout<<"Введите число a: ";</span>    
double a,b;
    
cin>>a;
    
cout<<"Введите число b: ";</span>    
cin>>b;
    
double **massiv=new double*[10];
for(int i=0;i<10;i++)</span>        
massiv[i]=new double[10];
for(int i=0;i<10;i++)</span>    
{
        
for(int j=0;j<10;j++)</span>        
{
            
massiv[i][j]=(double(rand()) / RAND_MAX) * (b - a) + a;
            
cout<<setw(6)<<setprecision(3)<<massiv[i][j];</span>        
}
        
cout<<endl;</span>    
}



Но не иначе. 


(1.5k баллов)