Написать программу нахождения суммы большего и меньшего из чисел a,b,c.

0 голосов
79 просмотров

Написать программу нахождения суммы большего и меньшего из чисел a,b,c.


Информатика (12 баллов) | 79 просмотров
Дан 1 ответ
0 голосов

всего три числа?

решу с рандомным заполнением...

 

на паскале: 

 

...

var

a,b,c:integer;

min, max:integer;

 

begin clrscr;

 

a:=random(10)+0;

b:=random(10)+0;

c:=random(10)+0;

 

if (a  min:=a

else

 if (c

  min:=c

 else

  min:=b;

 

if (a>b) and (a>c) then

 max:=a

else

 if (c>a) and (c>b) then

  max:=c

 else

  max:=b;

 

writeln('Максимальное: ',max);

writeln('Минимальное: ',min);

 

readkey;

end.

(20 баллов)