Программирование.Язык Паскаль.Помогите пожалуйста,нужно нарисовать блок схемы и написать...

0 голосов
51 просмотров

Программирование.Язык Паскаль.
Помогите пожалуйста,нужно нарисовать блок схемы и написать программы

1)Дана строка и буква. Определить сколько слов в строке начинается на эту букву.Вывести эти слова.


2)Составить программу,которая в заданном слове с дефисом меняет местами части до и после дефиса


Информатика (159 баллов) | 51 просмотров
Дан 1 ответ
0 голосов

2 задача
var   
   s,a,b:string;
begin     
   writeln('Введите слово: ');  readln(s);     
   b:=Copy(s,1,Pos('-',s)-1);     
   a:=Copy(s,Pos('-',s)+1,Length(s)-Length(b));     
   writeln(a,'-',b);
end.

(221 баллов)