Составить программу ** языке Паскаля: Даны числа a,b,c. Составить программу, выводящую **...

0 голосов
51 просмотров

Составить программу на языке Паскаля: Даны числа a,b,c. Составить программу, выводящую на экран сообщение, в зависимости от того какой треугольник можно построить с такими длина сторон: равносторонний,равнобедренный или какой либо другой.


Информатика (28 баллов) | 51 просмотров
Дан 1 ответ
0 голосов

var a,b,c: integer;

begin

  readln(a,b,c);

  if (a>b+c) or (b>a+c) or (c>a+b) then begin writeln('Треугольник не сущесвует'); exit; end;

  if (a=b) or (b=c) or (a=c) then writeln('Равнобедренный треугольник');

  if (a=b) and (b=c) and (a=c) then writeln('Равносторонний треугольник');

  if (sqr(c)=sqr(a)+sqr(b)) or (sqr(b)=sqr(c)+sqr(a)) or (sqr(a)=sqr(b)+sqr(c)) then writeln('Прямоугольный треугольник');

end.

(2.1k баллов)