Написать программу которая получает два целых числа и находит их произведение не...

0 голосов
130 просмотров

Написать программу которая получает два целых числа и находит их произведение не используя операцию умножения учтите что числа могут быть отриц


Информатика (19 баллов) | 130 просмотров
Дано ответов: 2
0 голосов
Правильный ответ

//PascalABC.NET версия 3.3.1590 от 03.12.2017
//Если программа не запускается, то обновите версию

var
    a, b, i, p: integer;

begin
    readln(a, b);
   
    p := 0;
    for i := 1 to abs(b) do
        p := p + abs(a);
   
    if sign(a) <> sign(b) then p := -p;
    writeln(p);
end.

(55.0k баллов)
0 голосов

Var a,b,p,n:integer;
begin
writeln ('Введите два числа:');
readln (a, b);
n:=abs(b);
if (a=0) or (b=0) then
writeln (a,'*',b,'=0')
else begin 
while (n<>0) do begin 
n:=n-1; 
p:=p+abs(a)
end; 
if (a>0) and (b>0) then writeln (a,'*',b,'=',p); 
if (a<0) and (b<0) then writeln ('(',a,')','*','(',b,')','=',p); <br>if (a>0) and (b<0) then writeln (a,'*','(',b,')','=-',p); <br>if (a<0) and (b>0) then writeln ('(',a,')','*',b,'=-',p); 
end;
end. 

(94.9k баллов)