Написать программу (в паскаль) по закупке товаров в магазине ** определённую сумму денег,...

0 голосов
83 просмотров

Написать программу (в паскаль) по закупке товаров в магазине на определённую сумму денег, не превышающую заданное количество денег.

ВХОДНЫЕ ДАННЫЕ: С клавиатуры вводится сумма, на которую предполагается произвести покупки. Затем вводятся цена и количество товара №1, товара №2 и т.д. до тех пор пока не будет исчерпана сумма денег.


Информатика (48 баллов) | 83 просмотров
Дано ответов: 2
0 голосов

Uses crt;
var s:integer;
     b,y,a:real;
begin
write('Введите сумму денег, на которую собираетесь произвести покупки: ');
read(a);
while a>0 do begin
  s:=s+1;
  write('Товар №',s,': ');
  read(b);
  write('Введите количество: ');
  read(y);
  a:=a-(b*y);
 end;
end.

(31 баллов)
0 голосов

Uses crt;
var
sum,x,itog: real;
i,y: integer;
begin
i:=1;
itog:=0;
write ('Start summa: ');
readln (sum);
while (itogbegin
write ('¹',i,': ');
i:=i+1;
readln (x);
write ('Kol-vo: ');
readln (y);
itog:=itog+y*x;
end;
if (itog>sum) then
writeln ('Itog: ',itog-y*x)
else
writeln ('Itog: ',itog);
end.

(2.8k баллов)
0

исправил, чтобы не превышало начальную сумму.

0

у меня меньше программа

0

я рад