Помогите с задачей!напишите программу определения стоимости разговора по телефону с...

0 голосов
112 просмотров
Помогите с задачей!
напишите программу определения стоимости разговора по телефону с учётом скидки 20% представляемой по субботам и воскресениям. Вычисление стоимости разговора по телефону. Введите исходные данные: Длительность разговора(целое количество минут)— 3 День недели(1-понедельник,...7-воскресенье)--5 Предоставляется скидка 20% Стоимость разговора: 5.52 руб. (она большая должна быть и для паскаля)!

Информатика (12 баллов) | 112 просмотров
0

Вроде, там про этого не чего не сказано...но я думаю за 1 мин

Дан 1 ответ
0 голосов

Program D1KPxx3;
uses crt;
var
i:integer;
min,rez:real;
b:char;
label 1,2;
begin
1:write('Введите время разговора');
read(min);
writeln('Введите номер дня недели');
read(i);
if (i=6) or (i=7) then
begin
rez:=((min*5.52)-(min*0.2));
write('Стоимость разговора с учетом скидки равна: ',rez);
goto 2;
end
else
rez:=min*5.52;
write('Стоимость разговора равна: ',rez);
2:writeln('Ещё??  Y/N');
readln(b);
if b='Y' then
goto 1;
if b='N' then
write('Пока!');
end.

(510 баллов)
0

Они одновременно и смешные и не понятные

0

просто проверь с калькулятором! возьми 10 минут в обычный день просчитай и в другой день!

0

только вот эту строчку исправь))) забыл кое что когда копировал))) rez:=((min*5.52)-(min*5.52*0.2));

0

а куда ее вставлять?)

0

вместо rez:=((min*5.52)-(min*0.2)); вставь rez:=((min*5.52)-(min*5.52*0.2));

0

кстати что такое rez?)

0

это результат, сколько стоить будет!)

0

Спасибо)

0

всегда пожалуйста)

0

))