Пожалуйста, помогите написать программу или хотя бы объясните, что от меня вообще...

0 голосов
53 просмотров

Пожалуйста, помогите написать программу или хотя бы объясните, что от меня вообще хотят....Найти количество элементов к каждому столбцу прямоугольной вещественной матрицы, меньших среднего арифметического всех элементов, рассмотренного столбца.


Информатика (20 баллов) | 53 просмотров
Дан 1 ответ
0 голосов

var a:array [byte,byte] of real;
i,j,n,m:byte;
s:real;
d,p:word;

begin
write('Введите количество строк n = ');readln(n);
write('Введите количество строк m = ');readln(m);
for i:=1 to n do
for j:=1 to m do
readln(a[i,j]);

s:=0;d:=0;p:=0;
for i:=1 to m do begin
for j:=1 to n do
s:=s+a[j,i];
for j:=1 to n do
if a[j,i]<(s/n) then inc(d);<br>writeln('Количество элементов в столбце ',i,' прямоугольной вещественной матрицы, меньших среднего арифметического d = ',d,' Среднее арифметическое = ',(s/n):0:4);
p:=p+d;
d:=0;s:=0;
end;
writeln('Общее количество элементов меньших элементов в столбцах = ',p);
writeln('Матрица');
for i:=1 to n do begin
for j:=1 to m do
write(a[i,j],' ');
writeln;
end;
end.

(265 баллов)