Помогите написать программу в паскате которая должна находить большую цифру числа (числа...

0 голосов
49 просмотров

Помогите написать программу в паскате которая должна находить большую цифру числа (числа integer) большая цифра числа это например число 53 большая это 5 а в числе 29 большая 9 и тд ХЕЛП


Информатика (64 баллов) | 49 просмотров
Дан 1 ответ
0 голосов

Program test;
var a,i,z,max:int64;
begin
readln(a);
for i:=1 to Length(InttoStr(a)) do
beginz:=a mod 10;
a:=a div 10;
if maxend;
writeln(max);
end.

(623 баллов)