Прошу помощи! Нужно написать программу для решения следующей задачи: вычислить количество...

0 голосов
40 просмотров

Прошу помощи! Нужно написать программу для решения следующей задачи: вычислить количество элементов числовой последовательности а, удовлетворяющих условию -0,2<=sin ai <=0,5, i=1, 2,..., n


Информатика (12 баллов) | 40 просмотров
Дан 1 ответ
0 голосов

#include
using namespace std;
void main()
{int n,k=0;float b=0;
cout<<"Vvedite n=";cin>> n;
cout<<endl;</span> float* f = new float [n];
for(int i=1;i<=n;i++)<br> {
cout<<"A["<<i<<"] = ";cin>>f[i];
}
for(int i=1;i<=n;i++)</span> {  
  b=f[i];
if(-0.2<=sin(b)<=0.5)<br> {       
   k++;  cout<<"Znachenie sinysa = "<<i<<"el-ta "<<sin(f[i])<<endl;</span>
}
b=0;
}
cout<<" Kol-vo ravno="<<k<<endl;</span>
system("pause");
}

(150 баллов)