Написать программу вычисления выражения с помощью цикла for 1!+2!+3!+...+n! уже не...

0 голосов
68 просмотров

Написать программу вычисления выражения с помощью цикла for 1!+2!+3!+...+n!
уже не соображаю..


Информатика (19 баллов) | 68 просмотров
Дан 1 ответ
0 голосов
Правильный ответ

Решите задачу:

var \ i,n,s:integer; \\ function \ fact(a:integer):integer; \\ begin \\ \ if \ a<=1 \ then \ fact:=1 \\ \ else \ fact:=a*fact(a-1); \\ end; \\ \\ begin \\ \ writeln('Vvedite \ n \ '); \\ \ readln(n); \\ \ for \ i:=1 \ to \ n \ do \ s:=s+fact(i); \\ \ writeln('Summa \ ravna \ ',s); \\ end. \\ \
(5.2k баллов)