Написать программу в Pascal ABC. Дана строка, слова в строке разделены пробелами, сколько...

+949 голосов
3.2m просмотров

Написать программу в Pascal ABC. Дана строка, слова в строке разделены пробелами, сколько слов в этой строке?


Информатика (22 баллов) | 3.2m просмотров
+133

Выставишь лучший ответ?

Дан 1 ответ
+149 голосов

Если считать, что количество пробелов между словами всегда равно 1, а также что нет пробелов до и после последовательности, то количество слов = количеству пробелов + 1.

Код:

  • program words;
  • var
  •    s: string;
  •    k, i: integer;
  • begin
  •    WriteLn('Введите последовательность слов с пробелами:');
  •    ReadLn(s);
  •    k := 1;
  •    for i := 1 to length(s) do
  •        if s[i] = ' ' then k := k + 1;
  •    WriteLn('Кол-во слов: ', k);
  • end.
(6.9k баллов)