) ** известном вам языке программирования напишите программу: Даны три целых числа....

+120 голосов
3.4m просмотров

) На известном вам языке программирования напишите программу: Даны три целых числа. Определить количество положительных чисел. Код программы:


image

Информатика (19 баллов) | 3.4m просмотров
Дано ответов: 2
+128 голосов
Правильный ответ

Ответ:

На Pascal:

var a,b,c,count:integer;

begin

readln(a);

readln(b);

readln(c);

count := 0;

if a > 0 then begin

  count := count + 1

end;

if b > 0 then begin

  count := count + 1

 end;

if c > 0 then begin

  count := count + 1

 end;

writeln(count);

end.

На Python:

a = int(input())

b = int(input())

c = int(input())

count = 0

if a > 0:

   count = count + 1

if b > 0:

   count = count + 1

if c > 0:

   count = count + 1

print(count)

Еще Python:

p = 0

for i in range(1,4):

   n = int(input())

   if n > 0:

       p += 1

print(f'Количество положительных чисел {p}')

(4.1k баллов)
+38

Венсент я выложил щас задание,помоги пожалуйста это прям срочное задание!!!!!!

+175

Можно

+170

А можно и в одну)

+163

Да что там Tolkuevgg так долго пишет, мне ответить не даёт, там решение в две строчки

+64 голосов

Ответ:

PascalABC.NET:

  • begin
  •    Println('Количество:', ReadArrInteger(3).Count(x -> x > 0));
  • end.

Объяснение:

Println(a,b) - выводит на экран a и b, разделяя их пробелом.

ReadArrInteger(3) - возвращает массив из 3 введённых чисел.

.Count(x -> x > 0) - считает количество элементов массива, удовлетворяющим условию x > 0, где x - элемент.


image
(3.7k баллов)
+72

Есть, просто PascalABC.NET позволяет написать это более читабельно (Намного более читабельно)
print(len(list(filter(lambda p: p>0, [int(input()) for i in range(3)]))))

+89

Прикольно, надо посмотреть есть ли подобное в python