Напишите программу ** Python Список квадратов Дано число N. Выведите N квадратов чисел...

+680 голосов
3.1m просмотров

Напишите программу на Python Список квадратов Дано число N. Выведите N квадратов чисел от 1 до N (включительно) в формате [1, 4, 9, 16,…, N**2]. Используйте функцию print() для вывода списка. Входные данные: В одной строчке дано натуральное число N≤200. Выходные данные: Список квадратов в указанном формате.


Информатика (15 баллов) | 3.1m просмотров
Дано ответов: 2
+74 голосов

Ответ:

N = int(input())

print([i**2 for i in range(1, N+1)])

(1.6k баллов)
+177 голосов

Ответ:

N = int(input())

arr = [0] * N

for i in range(1,N + 1):

   arr[i - 1] = i ** 2

print(arr)

1 строка - ввод числа N

2 строка - создание массива на N элементов, заполненных нулями

3 строка - цикл на N шагов, где i будет изменяться от 1 до N включительно

4 строка - массивы нумеруются с 0, так что i - 1. Заполнение массива квадратами

5 строка - вывод. Если вывести массив такой командой, то он выведется в нужном формате

(172 баллов)
+64

Почитайте на досуге что такое генераторы списков и списочные выражения в Python. Ваш код делает слишком много бесполезных действий.