Написать программу,инвертирующее байтовое число. Т.е. число 25 превратит в -25. Число...

+451 голосов
5.6m просмотров

Написать программу,инвертирующее байтовое число. Т.е. число 25 превратит в -25. Число -127 превратит в 127.


Информатика (49 баллов) | 5.6m просмотров
+115

Какой язык?

Дан 1 ответ
+122 голосов

С++

Ответ:

#include

int main() {

 char a = 25, b = -127;

 a = ~a;

 a++;

 b = ~b;

 b++;  

 printf("%d %d", a, b);

}

Версия с вводом числа (терминал)

#include

int main() {

 char a;

 std::cout << "Type your num: ";</p>

 std::cin >> a;

 a = ~a;

 a++;

 printf("Your inverse num: %d", a);

}

(3.1k баллов)