Плачу бобриными слезами!!! Помогите!!! Питон! Напишите программу, которая ищет среди...

+729 голосов
742k просмотров

Плачу бобриными слезами!!! Помогите!!! Питон! Напишите программу, которая ищет среди целых чисел, принадлежащих числовому отрезку [a;b][a;b] простые числа. Выведите все найденные простые числа в порядке возрастания, слева от каждого числа выведите его номер по порядку. Числа aa и bb натуральные числа, вводятся с клавиатуры, каждое с новой строки, причем a Sample Input: 3532000 3532160 Sample Output: 1 3532007 2 3532019 3 3532021 4 3532033 5 3532049 6 3532091 7 3532103 8 3532121 9 3532147


Информатика (239 баллов) | 742k просмотров
Дан 1 ответ
+115 голосов

Ответ:

a=int(input())

b=int(input())

c=b+1

k=0

p=0

for i in range (a,c):

   for j in range (2,i):

       if i%j==0:

           if i==j:

               break

           else:

               k+=1

               break

   if k==0 and i!=1:

       p+=1        

       print (p, i)

   k=0

a=int(input())

b=int(input())

c=b+1

k=0

p=0

for i in range (a,c):

(tab)for j in range (2,i):

(tab)(tab)if i%j==0:

(tab)(tab)(tab)if i==j:

(tab)(tab)(tab)(tab)break

(tab)(tab)(tab)else:

(tab)(tab)(tab)(tab)k+=1

(tab)(tab)(tab)(tab)break

(tab)if k==0 and i!=1:

(tab)(tab)p+=1

(tab)(tab)print (p, i)

(tab)k=0

Объяснение:

Проверять тут: https://repl.it/languages/python3

Остальные компиляторы могут не доводить программу до конца из-за большого количества действий

Если мой ответ оказался Вам полезен, то прошу отметить его, как "лучший"


image
(1.6k баллов)
+127

тааак.. Это была моя ошибка, прошу прощения!! Все исправленно!!))))

+195

Ох, но вот ответ необходимо слева от каждого числа выведите его номер по порядку..Вы случайно не знаете как это сделать?)))

+189

а, сейчас

+118

Готово

+35

Заковыристая задача, тебе где такую дали?

+109

О бооооже,неужели случилось!?!? Я не верю своим глазам!! ААА, от всего сердца спасибо Вам, товарищ!!

+102

Это в гимназии 10 класса такую задают))

+100

Это однозначно лучший ответ!!))) СПАСИБО!!!

+181

А с++ можешь сделать??

+65

Нет, только питон